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1.  Prerequisites 
Required Items 

•​ Windows PC or VPS with MetaTrader 4/5 installed 
•​ MT4 or MT5 trading account (broker account) 
•​ MT4/5 Agent account (email + password) 
•​ Stable internet connection 

 

💡  Supported Brokers: Compatible with all brokers supporting MT4/MT5, including FTMO, 
MyFxFunds, FBS, Moneta Markets, IC Markets, and most others. 

 

System Requirements 

Item Requirement 

Operating System Windows 7 or later 

MT5 Version Build 2000 or higher (latest recommended) 

MT4 Version Build 1000 or higher 

Internet Stable connection (VPS recommended) 

Browser Chrome, Firefox, Safari, Edge (for dashboard) 

 

2.  Sign Up & Email Verification 
2-1. How to Sign Up 

1.​ Open your browser and go to https://mtagent.online 
2.​ Click "No account? Sign up" at the bottom of the login screen 
3.​ Enter your email address and password (minimum 8 characters) 
4.​ Click "Create Account" 

 

📧  A verification email is sent immediately after registration. Check your inbox (including spam 
folder). 

 

2-2. Email Verification 
5.​ Open the [MT4/5 Agent] verification email and click "Verify Email" 
6.​ You will be automatically redirected to the dashboard 
7.​ Confirm the "✅ Email Verified!" message and log in 

 

⚠️  Verification links expire after 24 hours. If expired, click 'Resend Verification Email' on the login 
screen. 
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2-3. Membership Plans 

Plan Price Accounts Key Features 

FREE $0 (forever) 3 Basic monitoring 

STARTER $29/mo 10 Copy Trading, Calendar, Prop, AI 5x/mo 

PRO $79/mo 50 AI 30x/mo, all features 

BUSINESS $199/mo Unlimited AI 100x/mo, all features 

 

2-4. Feature Comparison by Plan 

Feature FREE STARTER PRO BUSINESS 

Real-time Monitoring & Remote 
Control 

✅ ✅ ✅ ✅ 

Copy Trading ❌ ✅ ✅ ✅ 

Economic Calendar Automation ❌ ✅ ✅ ✅ 

Prop Firm Management ❌ ✅ ✅ ✅ 

Telegram Alerts ❌ ✅ ✅ ✅ 

AI Trading Analysis ❌ 5x/mo 30x/mo 100x/mo 

PDF Performance Report ❌ ✅ ✅ ✅ 

VPS Monitoring ❌ ✅ ✅ ✅ 

Command Scheduler ❌ ✅ ✅ ✅ 

Signal Market ❌ ✅ ✅ ✅ 
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3.  MT5 Required Settings  ★ IMPORTANT 
⚠️  CRITICAL: Without these settings, the EA cannot communicate with the server and will not 
function correctly. The EA will NOT connect to the dashboard without completing these steps. 

 

3-1. Allow DLL Imports 
8.​ In MT5 top menu → click [Tools] → [Options] 
9.​ Click the [Expert Advisors] tab 
10.​Check the "Allow DLL imports" checkbox ✓ 
11.​Click [OK] to save 

 

3-2. Allow WebRequest (Server Communication) 
12.​In MT5 top menu → click [Tools] → [Options] 
13.​Click the [Expert Advisors] tab 
14.​Check the "Allow WebRequest for listed URL" checkbox ✓ 
15.​Add the following URL: https://mtagent.online 
16.​Click [OK] to save 

 

⚠️  Enter the URL exactly as: https://mtagent.online (no trailing slash). Settings apply immediately 
without restarting MT5. 

 

4.  EA File Download & Installation 
4-1. Download EA 
Download from the dashboard:  Settings ⚙ → scroll down → [📥 EA Download] section 
Or access directly: https://mtagent.online/download/ea 
 

EA Type Filename (example) Platform 

MT5 EA MT5_Agent_EA_V3_7.ex5 MetaTrader 5 only 

MT4 EA MT4_Agent_EA_V3_7.ex4 MetaTrader 4 only 

 

💡  EA version number is included in the filename (e.g., V3_7). When updating, replace with the new 
version file. 

 

4-2. MT5 EA File Installation 
17.​Click [MT5 EA] button → download MT5_Agent_EA_V3_x.ex5 
18.​Open MT5 → top menu → [File] → [Open Data Folder] 
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19.​Navigate to MQL5 → Experts folder and paste the .ex5 file 
20.​In MT5 [Navigator] panel → right-click Expert Advisors → [Refresh] 

 

4-3. MT4 EA File Installation 
21.​Click [MT4 EA] button → download MT4_Agent_EA_V3_x.ex4 
22.​Open MT4 → top menu → [File] → [Open Data Folder] 
23.​Navigate to MQL4 → Experts folder and paste the .ex4 file 
24.​In MT4 [Navigator] panel → right-click Expert Advisors → [Refresh] 
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5.  MT5 EA Configuration & Account Connection 
5-1. Apply EA to Chart 

25.​Open any symbol chart in MT5 (any symbol works) 
26.​[Navigator] → [Expert Advisors] → double-click or drag MT5_Agent_EA 
27.​When the EA settings window opens, click the [Inputs] tab 

 

5-2. Required Settings 

Setting Value Description 

ServerURL https://mtagent.online Domain only (no path) 

InpAgentEmail your@email.com Same as login email 

InpAgentPassword your password Changeable after first login 

InpPollInterval 3 (default) Command polling interval 
(seconds) 

InpAccountAlias e.g. Gold_Real Display name on dashboard 

InpAllowAlgoCtrl true Allow remote Algo control 

InpAllowClose true Allow remote position close 

InpFillingMode 0 = Auto detect Try 1(IOC) or 2(FOK) if broker 
errors occur 

 
28.​Click [OK] to apply the EA 
29.​Enable the [AutoTrading] button at the top of MT5 (green) 
30.​Confirm the smiley face icon :-) in the top-right of the chart 

 

✅  After logging into the dashboard (https://mtagent.online), if the account shows ONLINE in Live 
Accounts — the connection is successful! 

 

💡  Filling Mode: If orders are not being placed with some brokers (e.g., FBS), set InpFillingMode to 1 
(ORDER_FILLING_IOC). 

 

6.  MT4 Agent EA Installation Guide 
💡  MT4 can only run one EA per chart. Prepare one dedicated chart for MT4 Agent EA (e.g., 
GBPUSD H1). 

 

6-1. MT4 Required Settings  ★ IMPORTANT 
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31.​MT4 top menu → [Tools] → [Options] 
32.​Click [Expert Advisors] tab 
33.​Check all 3 items below: 
•​ Allow automated trading 
•​ Allow DLL imports ★ 
•​ Allow WebRequest for listed URL ★ 
34.​Add to WebRequest URL list: https://mtagent.online 
35.​Click [OK] then restart MT4 (fully close and reopen) 

 

6-2. EA Settings & Account Connection 

Setting Value Description 

ServerURL https://mtagent.online Domain only (no path) 

InpAgentEmail your@email.com Same as login email 

InpAgentPassword your password Changeable after first login 

InpPollInterval 3 (default) Command polling interval (seconds) 

InpAccountAlias e.g. Gold_Real Display name on dashboard 

InpVpsName e.g. VPS-01 (optional) Enter for VPS monitoring 

 

6-3. Additional EA Registration (MT4 specific) 
Since MT4 can only run one EA per chart, use the Additional EA fields to display other 
commercial EAs running on other charts in the dashboard: 
 

Setting Format Example 

Additional EA 1 EAname,Symbol,Timeframe GoldScalper,XAUUSD,60 

Additional EA 2 EAname,Symbol,Timeframe ScalpEA,EURUSD,5 

Additional EA 3~4 (leave blank to ignore) - 

 

6-4. MT4 vs MT5 Differences 

Item MT5 MT4 

EA file extension .ex5 .ex4 

Data folder path MQL5/Experts MQL4/Experts 

Auto Trading button AutoTrading Auto Trading 

EA list collection All charts automatic Manual registration required 

Partial close Supported (V3.1+) Supported (V3.1+) 

Event-based copy Supported (V3.7+) Supported (V3.7+) 
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7.  Dashboard Overview 
Log in with your email and password at https://mtagent.online 
 

7-1. Tab Layout 
Tab Description 

Live Accounts Registered account list — click account to show detail panel 

Positions Consolidated view of all open positions across accounts 

Trading Copy Trading, Signal Market sub-menus 

Analytics Performance analysis, monthly P/L, trade analysis, PDF report 

Tools Calendar automation, Prop Firm management, Scheduler 

More EA list, Risk management, additional features 

📢 Notice Service announcements (NEW badge alerts) 

 

7-2. Side Panel (click an account to show on the right) 
•​ CONNECTION — Account info, balance, equity, margin level 
•​ QUICK COMMANDS — Algo ON/OFF, close all, filter close, new order 
•​ Today's trade history — closed trades for today 
•​ 🤖 AI Trading Analysis — Claude AI performance analysis & recommendations 
•​ 🏦 Prop Trading — FTMO DD/Profit real-time monitoring 
•​ 🛡 Risk Management — Automatic margin level response 
•​ 🎯 Daily Target / Stop Loss — Daily profit target & loss limit 
•​ 📈 Performance — Balance/Equity chart, performance summary 
•​ 🔔 Telegram Alerts — Bot token and chat ID setup 

 

8.  Copy Trading Setup 
Automatically copies positions from a master account to slave accounts. 
 

8-1. Basic Setup 
36.​Click [Trading] → [Copy Trading] tab 
37.​Select master account (source account to copy from) 
38.​Select slave account (target account — must be different from master) 
39.​Set lot size: ratio (e.g., 0.5 = half of master) or fixed lot 
40.​Enter symbol filter (optional, e.g., XAUUSD,EURUSD — blank = all) 
41.​Click [➕ Add Copy Setting] then [▶ Start] to activate 
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⚡  Copy Trading Speed: With EA V3.7 event-based architecture, positions are copied within 1~2 
seconds of the master opening. A 30-second polling safety net is also maintained. 

 

8-2. SL/TP Configuration 

Setting Behavior 

Default (SL/TP not set) Slave closes automatically when master closes (SL/TP values not 
passed) 

Advanced > Copy SL checked Master's SL value is passed to slave as-is 

Advanced > Copy TP checked Master's TP value is passed to slave as-is 
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9.  Copy Trading Advanced Options 
Click [▶ Advanced Options] in the settings form to expand advanced settings. 
 

9-1. Symbol Mapping 
Use when symbol names differ between MT4 and MT5. 
Format: MasterSymbol=SlaveSymbol (comma-separated) 
Example: XAUUSD=GOLD,EURUSD=EURUSD.i 
 

9-2. Lot Size Limits 
Set minimum and maximum lot sizes for copied trades: 

•​ Min Lot — Minimum lot size (default: 0.01) 
•​ Max Lot — Maximum lot size (default: 100) 

 

9-3. Magic Filter 
Copy only positions with specific Magic Numbers. 
Example: 1001,1002 — leave blank to copy all positions 
 

9-4. Copy Pending Orders 
When enabled, BUY LIMIT / SELL LIMIT / BUY STOP / SELL STOP pending orders are also 
automatically copied to slave accounts. 

💡  Requires EA V3.7 or later. Pending order cancellations on the master are also automatically 
reflected on the slave. 

 

9-5. Loss Limit Auto Stop 
Automatically stops copying and sends a Telegram alert when the set loss limit is exceeded. 

Setting Description 

Amount Limit ($) Dollar-based loss limit. e.g., 100 → stop at -$100. 0 = disabled 

Ratio Limit (%) Percentage of slave balance. e.g., 5 → stop at -5%. 0 = disabled 

Period Daily / Total / Both 

 

💡  To resume after a loss limit stop: click [🔓 Reset] next to the ⛔ indicator in the Copy Settings list. 

 

9-6. Max Open Positions 
Limit the maximum number of simultaneously open positions on the slave account. 
Example: 5 → pause copying if 5 positions already open. 0 = unlimited 
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9-7. Trading Hours Filter 
Restrict copy trading to specific time windows only. 
Example: Start 09:00 / End 17:00 → new positions copied only during those hours 
 

9-8. Telegram Alerts 
Toggle alerts individually for Copy trading events: 

•​ On Open — Alert when a copy trade is opened 
•​ On Close — Alert when a copy trade is closed 
•​ Loss Limit Hit — Alert when loss limit is exceeded 

💡  Alerts require Bot Token and Chat ID to be configured in the master account's side panel → 🔔 
Telegram Alerts. 

 

9-9. Copy Performance Statistics 
Check the [📈 Copy Performance] section at the bottom of the Copy Trading tab: 

•​ Total PnL — Overall profit/loss 
•​ Win Rate — Percentage of winning trades 
•​ Trades — Total number of trades 
•​ Avg PnL — Average profit/loss per trade 
•​ Daily PnL chart — Last 30 days bar chart 
•​ By Symbol — Performance table by symbol 
•​ Period filter — Today / 7 Days / 30 Days / All Time 
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10.  Economic Calendar Automation 
Automatically turns Algo Trading off and on before and after major economic indicator releases. 
 

42.​Click [Tools] → [Calendar] tab → review event list (🔴 High Impact events shown at top) 
43.​In the account automation settings at the bottom, select an account 
44.​Check "Enable News Auto Algo OFF/ON" 
45.​Impact level: 🔴 High only recommended (High+Medium is too frequent) 
46.​Currency filter (optional, e.g., USD,EUR — blank = all currencies) 
47.​OFF N minutes before event: 5 min / ON N minutes after event: 15 min recommended 
48.​Click [💾 Save] 

 

📅  Event Auto-Update: ForexFactory event list is automatically refreshed from the server every hour. 

📣  Telegram Channel: Subscribe to @mtagent_support to receive daily high-impact economic events 
every morning at 8:00 AM KST. 

 

11.  Prop Firm (FTMO) Setup 
Automatically monitors DD limits for FTMO Challenge and Funded accounts. 
 

49.​In Live Accounts, click the Prop account → open side panel 
50.​Click [🏦 Prop Trading] section to expand 
51.​Select phase from FTMO Quick Setup (Phase 1 / Phase 2 / Funded) 
52.​Enter account size (e.g., 10000) 
53.​Click [💾 Save] → real-time Safety Score monitor activated 

 

FTMO Default Rules 

Phase Daily DD Limit Max DD Limit Profit Target 

Phase 1 (Challenge) 5% 10% 10% 

Phase 2 (Verification) 5% 10% 5% 

Funded Account 5% 10% None 

 

🚨  When DD limit is reached: all positions are automatically closed + Algo OFF is triggered. A 
Telegram alert is also sent. 

 

12.  AI Trading Analysis 
Claude AI analyzes recent trade data to provide improvement points and recommendations. 
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54.​Click an account in Live Accounts 
55.​Side panel → expand [🤖 AI Trading Analysis] 
56.​Select period (30 days recommended — more data = better accuracy) 
57.​Click [🤖 Analyze] button (first analysis takes 10~20 seconds / cached for 24 hours) 

 

Analysis Item Content 

Overall Assessment One-line summary of current trading level 

Risk Level LOW / MEDIUM / HIGH with reasoning 

Strengths / Weaknesses 3 each, with specific figures 

Key Insights Hidden pattern discovery (e.g., losses concentrated on Fridays) 

Recommendations 3 specific actionable steps 

 

📄  AI analysis results are automatically included in PDF reports. Click the [📄 PDF] button in the 
Stats tab or Performance panel after analysis is complete. 

 

13.  Signal Market 
Discover and subscribe to signals from verified professional traders. 
 

58.​Click [Trading] → [Signal Market] tab 
59.​Browse providers sorted by ranking score (returns, win rate, ratings, subscribers) 
60.​Click [View Detail] to see full performance breakdown, monthly return chart, and reviews 
61.​Click [Free Trial] to try with no payment (trial period set by provider) 
62.​Click [Subscribe Now] to subscribe (Monthly / Quarterly / Yearly plans) 

 
•​ Top 3 ranked providers are highlighted with 🥇🥈🥉 badges 
•​ Payment accepted via USDT, USDC, BTC (crypto) 
•​ Copy Trading is automatically configured upon payment 
•​ Public performance page available at: mtagent.online/signal/[ID] 

 

💡  Signal providers can share their public performance URL without requiring subscribers to log in. 

 

14.  Notices 
•​ Click [📢 Notice] tab at the top of the dashboard 
•​ A red blinking dot appears on the tab when there are new notices 
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•​ Click the [✕] button on each notice to hide it individually 
•​ Notices are managed per user and do not affect other users 

 

15.  EA Update Procedure 
When a new EA version is released, follow these steps: 
 

63.​Dashboard ⚙ Settings → [📥 EA Download] section → download new version 
64.​Open MT4/5 data folder → navigate to MQL4(5)/Experts folder 
65.​Replace old EA file with new file (overwrite or delete old version first) 
66.​MT4/5 [Navigator] → right-click Expert Advisors → [Refresh] 
67.​Remove EA from chart, then reapply with new version 

 

⚠️  After replacing with new EA, you must re-enter all settings (Email, Password, ServerURL, etc.). 
Settings are not carried over automatically. 

💡  Check current EA version from the filename: e.g., MT5_Agent_EA_V3_7.ex5 → V3.7 

 

16.  Account Settings & Withdrawal 
16-1. Change Password 

•​ Dashboard top right ⚙ Settings button → Change Password 
•​ After changing password, update the new password in EA settings as well 

 

16-2. Account Withdrawal 
•​ Dashboard top right ⚙ Settings button → scroll down → [🚪 Withdraw Account] button 
•​ Enter withdrawal reason (optional) and confirm with password 

 

⚠️  Upon withdrawal: subscription is automatically cancelled, connected MT4/MT5 accounts are 
unlinked, and Copy Trading settings are deactivated. Data is retained for 30 days then permanently 
deleted. 

 

17.  Mobile App Installation (PWA) 
Add to your home screen from your browser to use like a native app — no app store required. 
 

17-1. iPhone Installation 

⚠️  Safari browser is required for iPhone installation. 
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68.​Open Safari and go to https://mtagent.online 
69.​Tap the ··· button at the far right of the bottom toolbar 
70.​Tap "Share" 
71.​Select "Add to Home Screen" 
72.​Confirm the name and tap "Add" in the top right 

 

17-2. Android Installation 
73.​Open Chrome and go to https://mtagent.online 
74.​After 3 seconds, tap "Add to Home Screen" banner at the bottom → tap "Install" 
75.​If no banner appears: Chrome top right ⋮ → Select 'Install App' 

 

Item iPhone Android 

Required Browser Safari Chrome 

Installation Manual (Share → Add to Home 
Screen) 

Auto banner or ⋮ menu 

Fullscreen Supported Supported 

App Updates Automatic Automatic 
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18.  Frequently Asked Questions (FAQ) 
 

Q. Account is not showing as ONLINE 
•​ Check MT4/5 Options → Expert Advisors → Allow DLL imports ★ 
•​ Check MT4/5 Options → Expert Advisors → Allow WebRequest + mtagent.online URL 

★ 
•​ Confirm MT5 [AutoTrading] button is green (active) 
•​ Check smiley face icon in top-right of chart (frown = error) 
•​ Verify email/password in EA settings are correct 

 

Q. Copy Trading is not working 
•​ Check that the market is open (closed on weekends/holidays) 
•​ Confirm both master and slave accounts are ONLINE 
•​ Check that Copy Trading is in [▶ Start] active state in the Copy Trading tab 
•​ Check if ⛔ stopped due to exceeded loss limit → click [🔓 Reset] 

 

Q. Copy Trade orders are not being filled on the slave 
•​ Check that InpAllowOrder is set to true in the slave EA settings 
•​ Some brokers (e.g., FBS) require InpFillingMode=1 (IOC) 
•​ If symbol names differ, configure symbol mapping in Advanced Options 

 

Q. Partial close is not reflected on the slave 
•​ Check that EA version is V3.1 or higher — partial close supported from V3.1 
•​ Update to latest version via ⚙ Settings → EA Download 

 

Q. Telegram alerts are not arriving 
•​ Check accuracy of Bot Token and Chat ID 
•​ Send /start command to the Telegram bot first 
•​ Click [TEST] button in the Telegram settings in the side panel to verify 

 

Q. How do I change my password? 
•​ Dashboard top right ⚙ Settings button → Change Password 
•​ After changing, update the new password in EA settings too 

 

Q. How do I update the EA? 
•​ Download latest version from ⚙ Settings → EA Download 
•​ Replace file in MT4/5 Experts folder, then reapply EA to chart 
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Q. I want to use Investor Password (read-only) for the master account 
•​ MT4/5 Agent EA supports read-only accounts as master accounts 
•​ Since the EA only reads position data, Investor Password works perfectly 

 

 

Additional Support 
Email: support@mtagent.online 

Dashboard: https://mtagent.online 
Telegram: @mtagent_support 
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